Partial Outage
Incident Report for LeadLenz
Resolved
Google Cloud, which powers LeadLenz, experienced a global outage. This incident has been resolved.
Posted Nov 15, 2023 - 19:30 EST
Investigating
Some users cannot access the web app. We are currently investigating the issue.
Posted Nov 15, 2023 - 16:45 EST
This incident affected: Mobile App (Android App, iOS App) and Web App.