Conversations Errors

Incident Report for LeadLenz

Resolved

We have resolved the issue.
Posted Mar 16, 2026 - 16:01 EDT

Update

We are continuing to investigate Conversations related issues within the CRM. Multiple reports have been received and our engineering team has been notified and is actively investigating the root cause.

We will provide updates as soon as more information becomes available.
Posted Mar 16, 2026 - 14:02 EDT

Investigating

We are currently investigating an issue where some users are missing conversations or getting an error when attempting to send messages.
Posted Mar 16, 2026 - 12:57 EDT
This incident affected: LeadLenz Systems (CRM).